Searshor Website Service Outage

Incident Report for Searshor Status

Resolved

Automated monitor confirms Searshor Website has recovered and is fully operational.
Posted Aug 25, 2026 - 18:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2026 - 17:20 UTC

Investigating

Automated monitor detected an outage for Searshor Website (HTTP 404 Not Found). Our engineers are investigating.
Posted Aug 25, 2026 - 17:05 UTC
This incident affected: Searshor Search engine.